IDE0006 warning and many others on new Cross Platform Xamarin app with a fresh install

I just installed Visual Studio 2017 on a PC running Windows 10, and created a Cross Platform Xamarin app (Blank and PLC) called "trial". Right off the bat, the following warning came up in the Errors box:

IDE0006 - Error encountered while loading the project. Some project pfeatures, such as full solution alaysisis for the failed project and projects that depend on it, have been disabled.

To see what caused the issue, please try below.

1. Close Visual Studio
2. Open a Visual Studio Developer Command Prompt
3. Set environment variable "TraceDesignTime" to true (set TraceDesignTime=true)
4. Delete .vs directory/.suo file
5. Restart VS from the command prompt you set the environment variable (devenv)
6. Open the solution
7. Check 'C:\Users\Me\AppData\Local\Temp\\trial.Android_*.designtime.log' and look for the failed tasks (FAILED)

Since then, I've tried creating many other apps, all of which start with at least that warning, and usually more. Searching for the other errors yields no results - searching for the IDE0006 one yields a few discussions with a few different suggestions, but I tried all of them, including various combinations of updating/reinstalling/using previous versions of packages, deleting the "System.ObjectModel" reference, restarting, cleaning, and rebuilding, and the errors are still there. I even tried uninstalling and reinstalling Visual Studio, but nothing changed.

Weirder still, when I run my Android project despite the errors, nothing happens. On my first install of Visual Studio, an Android emulator popped up -
the screen was completely black which I doubt is expected behavior but at least the emulator was there - but ever since the reinstall, no emulator at all comes up, and all errors and warnings just disappear from the Error box, so the box is totally empty (although the top bar still displays "1 Warnings"), and I can't get them to come back. I set up my Android project exactly as prescribed on the Xamarin Windows setup page.

I started to follow the 7 steps outlined in the error, but I couldn't find any ".vs" directory or ".suo" file. It also occurred to me that deleting files without knowing what I'm doing for might screw up my Visual Studio even further.

Here are some of the other warnings that keep popping up - I assume/hope that all the warnings are caused by the same fundamental error, but I can't find any record on the internet of anyone else encountering any but the one above.

Cannot resolve Assembly or Windows Metadata file 'System.Runtime.dll'   trial.UWP   C:\Users\User\source\repos\trial\trial\trial.UWP\trial.UWP.csproj

Type universe cannot resolve assembly: System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=jf98hs8fsihso9. trial.UWP

Could not load assembly 'trial, Version=0.0.0.0, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile?   trial.Android

The "ResolveLibraryProjectImports" task failed unexpectedly.
System.IO.FileNotFoundException: Could not load assembly 'trial, Version=0.0.0.0, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile?
File name: 'trial.dll'
   at Java.Interop.Tools.Cecil.DirectoryAssemblyResolver.Resolve(AssemblyNameReference reference, ReaderParameters parameters)
   at Java.Interop.Tools.Cecil.DirectoryAssemblyResolver.Resolve(String fullName)
   at Xamarin.Android.Tasks.ResolveLibraryProjectImports.Extract(DirectoryAssemblyResolver res, ICollection`1 jars, ICollection`1 resolvedResourceDirectories, ICollection`1 resolvedAssetDirectories, ICollection`1 resolvedEnvironments)
   at Xamarin.Android.Tasks.ResolveLibraryProjectImports.Execute()
   at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
   at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__26.MoveNext() trial.Android   

I've been tearing my hair out over this. I was really looking forward to learning Xamarin but I literally haven't been able to code a single line yet. What could be going on?? It's like my installation is corrupted or something, but I don't see how that is possible, especially since I downloaded it twice, from the official download page.

Sign In or Register to comment.