Getting Authentication Service Not Available

attyranattyran USMember ✭✭

Hello,

I am using fastlane for Visual Studio for iOS provisioning, and would occasionally get the error below. Any ideas why this would happen? Very frustrating, and I can't figure out what is wrong?

Thanks

Best Answer

  • attyranattyran USMember ✭✭
    Accepted Answer

    FYI for anyone having trouble still. I ended up just disabling fastlane and just installing a dist cert and provisioning profile manually (ie via apple dev portal). This worked consistently.

Answers

  • BrianTBrianT USMember

    I am facing the same problem here while Apple Dev account is still valid on the portal.

  • DamianCanabalDamianCanabal USMember

    I'm getting this error but all the time.
    Cannot add Apple accounts or update Signing identities for the selected team. Always get the same error: Authentication Service Unavailable. Can log in normally to iTunes connect or Apple dev website.

  • JoeGilkeyJoeGilkey USMember

    I have also received the same warnings over the past few days.

  • JaaqJaaq MXMember ✭✭

    any solution?

  • DamianCanabalDamianCanabal USMember

    I think it's the issue on Apple's side:

    I was able to use my apple id to sign in on my iPhone, my Mac Book (iCloud), iTunes application, App Store application, Xcode, Apple Developer website.
    BUT
    I was unable to access apple id configuration page, iCloud or iTunesConnect websites using the same apple id or add apple id to VS Apple devs accounts

    I also was able to reset my password, reset security questions, setup 2 factor authentication for the apple id.
    At some point I was able to login to apple id configuration page and got VS to correctly use 2 factor authentication to set the apple developer account but after few minutes the 'Authentication Service Unavailable' reappeared and I could not log in to apple id configuration page again.

  • attyranattyran USMember ✭✭
    Accepted Answer

    FYI for anyone having trouble still. I ended up just disabling fastlane and just installing a dist cert and provisioning profile manually (ie via apple dev portal). This worked consistently.

Sign In or Register to comment.