Update 4.7.10.22 Does Not Install

The Xamarin Updates dialog in Visual Studio shows that I have version 4.7.10.22 ready to install. (This forum won't allow me to post the screenshot - The dialog says that Xamarin 4.7.10.22 is "Download completed. Pending to install.") But when I click on Install, the dialog closes and nothing happens. I tried the usual restarts (both PC and VS), but no success. Here's my specs:
Windows 7 64-bit
Visual Studio Enterprise 2015 Update 3
Xamarin 4.5.0.476 (1be4f0c)
Xamarin.Android 7.3.1.2 (9dbc4c5)
Xamarin.iOS 10.10.0.35 (4cffddf)

Posts

  • JonathanEckJonathanEck USMember

    As of today, now the latest version is 4.7.10.33, but my problem is still the same. Clicking on Install does nothing but close the dialog.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    You might be able to work around the problem by running the cached downloaded installer by hand, located in:

    %LOCALAPPDATA%\MonoDevelop-4.0\Cache\TempDownload

    For further investigation in case that is unsuccessful, you can file a quick bug report using the "15.4 Release" new bug form. Thanks in advance!

    (For quick reference, I double-checked the update behavior briefly in one local test Visual Studio 2015 environment, starting with Xamarin 4.7.10.22 for Visual Studio 2015, downloading the update for 4.7.10.33, and then clicking the Install button. The installer ran as expected for that quick test, so I expect there are some specific environment details needed to hit the issue. The team can help investigate further on a bug report.)

  • JonathanEckJonathanEck USMember

    Thank you. I had search my computer diligently for the cached download, but was unsuccessful because I was looking in folders named Xamarin. I did manage to locate the installer by Googling the exact string "Xamarin.VisualStudio_4.7.10.22.msi". However when I ran it, my Visual Studio Xamarin tools extension wouldn't load; whenever I opened a Xamarin project an error message was shown and the solution wouldn't load. So I completely uninstalled and reverted to version 4.5 to get it working again. My question now, is 4.7 not compatible with Windows 7?

Sign In or Register to comment.