Forum Xamarin Xamarin.iOS

I get an error only when deploying to iOS on Xamarin Live

RandyGuayRandyGuay USMember ✭✭


I have the Phoneword app working on Android (both the simulator and Xamarin Live) and the Windows Universal app. There is no build error. But when I try to deploy to iOS using Xamarin Live, I get the following error:

The type or namespace name 'IDialer' could not be found
The type or namespace name 'App" could not be found

I searched for these errors, and tried updating the Xamarin.Forms package, but the error is still there.

I don't have access to a Mac, so I can't try a real deployment.

Any ideas?


  • RandyGuayRandyGuay USMember ✭✭
    edited November 2017

    I get a different error on the iPhone 5S. The previous error was on iPhone 6. I can't post the image, but it begins,
    "Unhandled error launching soft debugger:System.NotSupportedException: This request is not supported by the protocol version implemented by the debuggee..."

  • JKS1909JKS1909 PLMember ✭✭

    I have the same error with Xamarin Live on iPhone 8+. Has anyone found a solution?

Sign In or Register to comment.