Forum Xamarin Xamarin.iOS

iOS Simulator never finishes starting

Hi,

I am developing on windows with VS Enterprise, and connected to a mac on the same network and am trying to run the simulator on windows. This was working fine for me a few weeks ago.

Now when I try to run the simulator (perhaps since updating VS and xamarin on my mac last week?) I get the iOS Simulator box and it gets stuck on Connected with the loading bar at the bottom showing its loading forever. Every once and a while it will change from Connected and go to Conneccting to Mac => Checking Server -> Connected, fairly quickly. It never actually starts though. Just seems to be in an endless loop.

Where should I look for problems? Is there a log I can look at? Has anyone else had this problem?

Answers

  • =(

  • TripleDoubleTripleDouble BGMember ✭✭✭

    I have the same problem. I am using mac cloud account.

    I have connected successfully , but iOS simulator is not showing., it is only writing connecting to mac

    Starting connection to Mac 87.237.60.244...
    Starting Broker 4.7.9.45 in port 56678...
    Connection successfully established with the Mac 87.237.60.244:56678
    Starting agents on Mac 87.237.60.244 (87.237.60.244)
    Starting Agent IDB 4.7.9.45...
    Starting Agent Build 4.7.9.45...
    Agent Build 4.7.9.45 is running
    Agent IDB 4.7.9.45 is running
    Connected to the Mac 87.237.60.244 (87.237.60.244) with Full support.

    Everything was ok yesterday .

    Any ideas ?

  • MihaMarkicMihaMarkic SI ✭✭✭✭

    Mine starts, but OS doesn't. v1.1.3.108

  • MihaMarkicMihaMarkic SI ✭✭✭✭

    I found out the problem - XCode required additional components to be installed. See bugzilla.

  • Yes, this worked for me. I had a new instance on MacInCloud, and Visual Studio would not connect until I launched Xcode on the hosted mac and built a simple empty project. Maybe that installed additional components or it launched the simulator on the remote computer.

  • nick5454nick5454 USUniversity ✭✭✭

    I found this happens when Mac farts. I have a test app on the Mac and I run it in the simulator to make sure xCode is happy.

    What I found is that the Mac holds on to the Socket and never releases it, sometimes. A restart clears the socket and all is well.

    If you look in the logs you'll see that the Socket connection is blocked when the MQTT call is made.

Sign In or Register to comment.