Misc. Problems with Visual Studio Editor

1) Each time I open Visual Studio Community for the first time, and open a storyboard file, it always shows me an error. I have to refresh, and then it works. (minor annoyance)
2) At times the simulator will stop showing newer builds. I must close out of both the simulator and Visual Studio in order to get it working again. (mid level annoyance)
3) The text cursor in the editor will disappear, sometimes after each letter I type. This makes coding extremely frustrating. (insane level of annoyance) BTW, no other editor does this. The error reporting code appears to be the thing stealing focus, as it only happens after I type a character.

I can live with issue #1. #2 is a pain, but #3 is impossible. Anyone else experience these issues? Workarounds?

Tagged:

Posts

  • JimBennettJimBennett GBInsider, University, Developer Group Leader ✭✭✭✭

    Have you reported these? Help->Report a problem

  • ChrisLarkinChrisLarkin USUniversity ✭✭

    Ditto on #3 and it is INCREDIBLY annoying.

  • Port25Port25 USMember ✭✭
    edited November 13

    Update on #2 and #3:

    2) I noticed this only happens when I switch simulators, or from a simulator to an actual device. Cleaning does not help; closing both the simulator and Studio appears to be the only fix.

    3) I have not been able to reproduce the issue when using an external mouse and keyboard; although, I tend to have the laptop always plugged in when I am working this way. I think the issue may be triggered if the laptop has come out of a hibernate state...I need to see if I can repro using the trackpad and builtin keyboard, and with the laptop plugged in.

Sign In or Register to comment.