Running app in simulator produces error "No installed provisioning profiles match the installed..."

SeanMPausSeanMPaus USUniversity

Hello,

I am trying to run my Xamarin.iOS app in one of the iOS 11.0.1 simulators. I receive the following error when I do:

/Users/spaus/mobile/gamifymobile/Deloitte.Mobile.Gam/Deloitte.Moble.Gamification.iOS.Today/Deloitte.Moble.Gamification.iOS.Today.csproj (Build) ->
/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets (_DetectSigningIdentity target) ->

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : No installed provisioning profiles match the installed iOS signing identities.

I have tried creating a developer distribution, but that did not help.

Any thoughts?

Answers

  • NigelWebberNigelWebber USMember

    My exact problem too. Unfortunately, Xamarin is 'Alpha' at best and loaded with annoying gotcha's like this one which prevent one actually getting any work done.

    A provisioning profile is NOT REQUIRED for building for the simulator, its only needed when deploying to a physical device for test purposes. I am seeing loads of folks with this error, but unfortunately no one having managed to solve it.

    Most of the solutions online pertain to deploying on physical devices, not the simulator and are thus unrelated to the specific error encountered here.

    In my case, a 'hello world' app builds in xcode on the mac , and deploys to the simulator on the mac. I have an apple ID, but not an apple developer account as I do not need one to deploy to the simulator.

    If you have since solved, please post up!

Sign In or Register to comment.