Forum Visual Studio

Xamarin.Android Toolbar does not show connected devices



  • I discovered that some USB (charging) cables will not connect my device to the PC. Make sure your USB cables carries data.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    Hi all

    I had a horrible experience just a few day ago.
    I have developed a business App (as part of a solution) and had to do an urgent update.
    The last update was just a few days ago - everything has worked as it should (I was able to debug to my Android devices multiple times without problems).
    Then, I wanted to do the urgent changes and... the mobile devices were not showed in the toolbar anymore... (from one day to the next)...
    So.. I first tried to do the known workarounds... unplug and plug the mobile devices... restart VS (I work with Windows 10 and VS 2015) multiple times... restart machine... and so on...
    Nothing has helped... panic came up...
    Then, I have investigated the Windows updates from last day (about 300 packages - no update to VS itself).
    I then have realized, that the MS "Mobile Companion" has caused the problem in my case.
    I never have installed the tool and also not want / need it... it seems as it was installed automatically (and "silent") with some of the "loved" automatic updates to Windows 10...
    However... I don't know the exact behavior yet (I have to investigate it more in detail), but if I have terminated the "Mobile Companion" (that is loaded automatically, I a devices is unplugged and re-plugged) a few times directly in task manager, the mobiles were found again.
    So.. if you have similar problems... this may be a workaround also for you...
    Hope this helps someone...

  • JocontacterJocontacter USMember ✭✭
    edited July 2018

    Hi all! i'm tried adb kill-server adb start-server, revoke authorizations, usb debugging on and off, restart vs many times. Sometimes it work(restart vs) sometimes no.
    As real only working and convenient solution for me is Tools-Android-Restart ADB from VS only! Try it!

    This case only if your problem is you see your device by "adb devices" command in cmd but not in VS toolbar. If not - check previous posts!

  • nhwillynhwilly USMember ✭✭

    5 years on and still getting this. Start/restart/start/restart/start/restart/start/restart/start/restart/ then it works.

  • GaryParkinGaryParkin USMember ✭✭

    @PainiRoger said:
    I have moved my development environment to a new computer and encountered this issue as well. I've installed everything but still no device.

    USB debugging on the phone was enabled but the trick was to disable and re-enable it which generates a new permission for the new computer.

    Yes, this is an old thread but it's still valid.

    Thank you sooooo much. Galaxy 9 phone.

  • For me unloading(right click-->Unload Project) and reloading(right click-->Reload Project) the .Android project fixed it. Which could work in place of restarting VS all the time.

  • mrooneymrooney Member

    Make sure the correct SDK is installed for the version of phone/tablet you are using. By default it sets to the latest version. I have an Oreo 8.1 version, and had to install that to get it to recognize my device.

  • ashika786ashika786 Member ✭✭

    I was able to see emulators and my physical device in dropdown. Tried different suggestions made in this post nothing worked. Turned out something small. I had minimized visual studio so dropdown would not show. Maximized vs window now I can see emulators as well as my device.

  • mohsinmohsin Member


Sign In or Register to comment.