Visual Studio for Mac, iOS bundle Signing Blank (No Content)

Installed VS 2017 Community Edition 7.2 yesterday (10/18), launched it for the first time, loaded my existing project, configured the bundle signing identity and side-loaded to a physical test device. At the end of the day, I closed VS. No problems right? Today I planned on creating a distribution build to deploy in-house to about 50K devices. I open VS, right click the iOS project, go to Options, navigate to iOS Bundle Signing option and the screen is blank! I restarted several times, still blank. So yesterday, the option had content and today I go to the same option and it is completely blank. Note, no updates where applied from yesterday to today. .

Posts

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
  • PaulLambertiPaulLamberti USMember ✭✭
    edited October 20

    ok. With xamarin already being as buggy as it is, how did something this important get released without first being tested. I am absolutely sick of dealing with the whole Xamarin development environment.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited October 20

    I'm just a member of the support team, so I'm not quite sure, but I suspect the key tricky thing about this issue from a testing standpoint was that the problem goes away if you install Xamarin.Mac (for example by enabling the macOS checkbox in the Visual Studio for Mac installer). I believe the iOS Bundle Signing page might also have been under more active development recently to integrate fastlane support than it had been for quite a while, so the combination of having Xamarin.iOS without Xamarin.Mac might not have ever come up before as an important variable to test. I believe there are plans to more strictly enforce the installation of Xamarin.Mac as a dependency for Xamarin.iOS in the future (and to increase testing coverage for similar installation scenarios where some components are deselected).

Sign In or Register to comment.