Debugger operation failed error

DanMiserDanMiser USMember ✭✭

After upgrading to VS Mac 7.2 (build 636), I'm getting this error message when trying to debug my iOS application.

Debugger operation failed
Could not load component

My Xcode is up to date at 9.0 and the Simulators show up both there and in VS Mac. I've tried a Rebuild All. I've tried to reinstall VS Mac. Nothing seems to get me to run the debugger in the Simulator. Any ideas on how to solve or further troubleshoot?

=== Visual Studio Community 2017 for Mac ===

Version 7.2 (build 636)
Installation UUID: cea389cb-2e89-4e49-8094-bb0e5bbdbdab
Mono (2017-06/71277e78f6e) (64-bit)
GTK+ 2.24.23 (Raleigh theme)

Package version: 504000201

=== NuGet ===


=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
SDK: /usr/local/share/dotnet/sdk/2.0.0/Sdks
SDK Versions:
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.4.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.6
Location: /Applications/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 9.0 (13247)
Build 9A235

=== Xamarin.iOS ===

Version: (Visual Studio Community)
Hash: 2f8bbec0
Branch: d15-4-xi
Build date: 2017-10-05 20:56:05-0400

=== Xamarin.Android ===

Version: (Visual Studio Community)
Android SDK: /Users/danmiser/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
7.1 (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.5
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

Android Designer EPL code available here:

=== Xamarin.Mac ===

Version: (Visual Studio Community)

=== Xamarin Inspector ===

Version: 1.2.2
Hash: b71b035
Branch: d15-1
Build date: Fri, 21 Apr 2017 17:57:12 GMT

=== Build Information ===

Release ID: 702000636
Git revision: b349c8fc0c2e1aab0179917d56eed75eb3a03337
Build date: 2017-10-06 15:20:04-04
Xamarin addins: a8da992c78f7eb65b3cdb3f951c34a30337cab35
Build lane: monodevelop-lion-d15-4

=== Operating System ===

Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
Thu Jun 15 17:36:27 PDT 2017
root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64


  • DanMiserDanMiser USMember ✭✭

    Trying to do a "Run | Start Without Debugging" gives this error:

    Cannot execute '/Users/danmiser/code/xamarin/Diary/Diary.iOS/bin/iPhoneSimulator/Debug/Diary.iOS.exe'

    That file definitely exists.

    Is there a way to get more log information so that I can get this working again?

  • DanMiserDanMiser USMember ✭✭
    edited October 2017

    This bugzilla issue looks like my issue, with the same MakeSimulatorGrabFocus exception in my IDE log. I'll follow up there because it claims to be fixed, but 7.3 isn't in the Alpha channel.

Sign In or Register to comment.