Application Loader - Java conflict?

IanVinkIanVink Ian VinkCAInsider, University ✭✭✭

I updated to the new Xcode and since then the Application Loader throws these errors after it tried to send the app to the iTunes.

Thought maybe someone else has this issue. I tried a full uninstall of Xcode , reboot and reinstall

Might this be an issue with Java?

An error occurred while starting bundles for the software update process. Transporter will try to continue. Unresolved constraint in bundle

com.apple.jingle.leghorn [5]: Unable to resolve 5.0: missing requirement [5.0] package; (package=com.sun.xml.bind.v2)
[2017-10-03 18:06:54 PDT]

INFO: Transporter is searching for updated software components.
[2017-10-03 18:06:54 PDT] INFO: No updates found.
[2017-10-03 18:06:55 PDT] INFO: MD5 checksum calculation in the transporter will be skipped.
[2017-10-03 18:06:55 PDT] INFO: Logging level set to eXtreme
[2017-10-03 18:06:55 PDT] INFO: Logging configured successfully.
[2017-10-03 18:06:55 PDT] DEBUG: Attempting refresh of configuration data from https://contentdelivery.itunes.apple.com/transporter/Defaults.properties
[2017-10-03 18:06:55 PDT] DEBUG: Configuration refresh successful.
[2017-10-03 18:06:55 PDT] DEBUG: Saving configuration to local path: /Users/vink/.itmstransporter/Defaults.properties
[2017-10-03 18:06:55 PDT] INFO: iTMSTransporter : iTunes Store Transporter [1.9.6]
[2017-10-03 18:06:55 PDT] INFO: OS identifier: Mac OS X 10.12.6 (x86_64); jvm=25.71-b02; jre=1.8.0-u131-b11-iTMSTransporter-b02
[2017-10-03 18:06:55 PDT] INFO: Memory: [JVM] 1023M free, 1050M total, 1820M max [System] (Physical) 46M free, 16384M total (Swap) 755M free, 1024M total
[2017-10-03 18:06:55 PDT] INFO: Client: Application Loader 3.7 (1034)
[2017-10-03 18:06:55 PDT] INFO: Upload mode selected.

An error occurred while trying to start transporter. Exception's name: java.lang.NoClassDefFoundError, Exception's message: org/springframework/util/backoff/ExponentialBackOff

Posts

Sign In or Register to comment.