xamarian studio won't start due to error on gtk-sharp?

I tried installing Xamarian Studio and it won't start. I checked the log files in C:\Users\lavendbr\AppData\Local\XamarinStudio-6.0\Logs and it reported the below error. I looked at my system and I had an old version of gtk-sharp 2.99.3. I had some problems removing the library since it couldn't find the original media. I used a tool from Microsoft to remove the gtk-sharp 2.99.3 and then I tried reinstalling gtk-sharp-2.12.45.msi several times. Each time, it seems to come up with the same error in the log file. I am not sure why it can't find the libraries. I have been going in circles on this. Any tips?

brian

System.TypeInitializationException: The type initializer for 'MonoDevelop.Ide.ImageService' threw an exception. ---> System.MissingMethodException: Method not found: '!!0[] System.Array.Empty()'.
at Gtk.IconFactory..ctor()
at MonoDevelop.Ide.ImageService..cctor() in C:\data\lanes\3510\0ccfcd52\source\monodevelop\main\src\core\MonoDevelop.Ide\MonoDevelop.Ide\ImageService.cs:line 49
--- End of inner exception stack trace ---
at MonoDevelop.Ide.ImageService.Initialize()
at MonoDevelop.Ide.IdeStartup.Run(MonoDevelopOptions options) in C:\data\lanes\3510\0ccfcd52\source\monodevelop\main\src\core\MonoDevelop.Ide\MonoDevelop.Ide\IdeStartup.cs:line 209
FATAL ERROR [2017-09-21 15:52:28Z]: Xamarin Studio failed to start. Some of the assemblies required to run Xamarin Studio (for example gtk-sharp)may not be properly installed in the GAC.
System.MissingMethodException: Method not found: '!!0[] System.Array.Empty()'.

Posts

  • AshleyGazichAshleyGazich USMember, Xamarin Team Xamurai

    Hi Brian, Xamarin Studio has been rebranded Visual Studio for Mac. Developers on Windows are encourages to migrate to Visual Studio. Otherwise, you could perhaps try an uninstall/reinstall using the last version from the account downloads page.

  • brazodemonobrazodemono USMember

    I installed Visual Studio community edition and I had a bit of trouble getting it working as it seems you have to install some components manually. I did get that working.

    I am now interested in using gtk-sharp for doing gui applications development using Visual Studio. What's the best approach to do that now? VSPrj2Make seems to be an old method.

Sign In or Register to comment.