Error While build the xamarin ios application after upgrading to IOS 11

SmartManSmartMan INMember ✭✭✭
edited September 2017 in Xamarin.iOS

Please find the below error:

Invalid architecture: ARMv7. 32-bit architectures are not supported when deployment target is 11 or later

Please give me your suggestions to solve this problem

Answers

  • ChrisColeTechChrisColeTech USMember ✭✭✭
    edited September 2017

    change the build architecture

    project properties -> ios build -> architecture

  • FritzLimFritzLim SGMember
    edited September 2017

    Besides changing the supported architectures to ARM64 (Project properties -> iOS Build -> Supported Architectures), you'll need to enable the "Perform all 32-bit float operations as 64-bit float." option.

    I have also posted a Q&A on this on Stack Overflow: https://stackoverflow.com/questions/46392966/error-in-xamarin-ios-arkit-demo-project-32-bit-architectures-are-not-supported.

  • SmartManSmartMan INMember ✭✭✭
    edited September 2017

    @KingChrisCole i have changed the architecture .But still have a issue. and Installed the all latest versions in both xamarin and xcode

  • MichaelGuzmanMichaelGuzman USMember ✭✭

    @SmartMan have you found a solution to this problem? I am also running into the same issue and have checked project properties to make sure I am selecting the correct architecture

  • JoschaJoscha Member

    @MichaelGuzman Did you change the two settings options as described by @FritzLim ?
    Worked for me, thanks btw guys :)

  • arueda_1980arueda_1980 Member ✭✭

    Hi. add into info.plis
    MinimumOSVersion
    9.1
    and try again

  • LuiginoDeTogniLuiginoDeTogni USMember ✭✭

    @arueda_1980 said:
    Hi. add into info.plis
    MinimumOSVersion
    9.1
    and try again

    Yes! This is THE fix :smile:

  • XamarinProblemsXamarinProblems Member ✭✭

    @arueda_1980 @LuiginoDeTogni
    This might make you able to compile the app and run in a simulator with the required OS, but if you release an App with a wrongly defined MinimumOSVersion, then you will allow users with to low OS version to download it and they will crash upon trying to launch it. - Just so you are aware

  • LuiginoDeTogniLuiginoDeTogni USMember ✭✭

    @XamarinProblems it's an issue of months ago, but if I well remember, this problem was about setting iOS 11 as development target: it's correct old iPhones 32bit do not work, so you can't deploy to them.
    I have an old iPhone 5 32bit, and i confirm my app, with development target 8, work without issues (app doesn't crash).
    App works also with newer iPhones (iOS 10, 11, all tested).

    Hi,
    Lewix

  • LuiginoDeTogniLuiginoDeTogni USMember ✭✭

    @ChrisColeTech said:
    change the build architecture

    project properties -> ios build -> architecture

    Other check to do

  • XamarinProblemsXamarinProblems Member ✭✭
    edited January 18

    @LuiginoDeTogni ye i know i just stumbled upon it in thought I'd mention the effect changing the minimum version of the build might do, so people would have an idea of where future issues might come from :)

    Sorry to bother you with the @'

  • MichaelGuzmanMichaelGuzman USMember ✭✭

    @Joscha I did try following @FritzLim suggestions and they did solve my issue once upon a time. I recently got the same issue and resolved it by toggling the "SDK Version:" field under Options -> iOS build from "Default" to my target. In this case it was "12.2" hope this helps. I would also recommend following the steps highlighted in the stack overflow link.

Sign In or Register to comment.