iOS 11.0 Simulators missing

SteveGraddySteveGraddy ✭✭USUniversity ✭✭

Updated two different MAC's to Xcode 9.0 this morning and none of the new simulators are visible in preferences on either machine.
Tried the below to add them and no iOS 11.0 simulators available.

Window > Devices and Simlators
Click on the + button at the bottom left corner
Choose 'Device Type': 'iPhone SE'
Then 'OS Version': 'iOS 11.0' not in list

Anyone have any suggestions?
Steve

Posts

  • JohnMillerJohnMiller Xamurai USForum Administrator, Xamarin Team Xamurai
    edited September 2017

    @SteveGraddy,

    After updating Xcode, make sure you also update your Xamarin tooling so that it's compatible. Make sure to also Open Xcode on the Mac 1 time so that it can initialize.

    https://releases.xamarin.com/stable-release-15-3-5-with-xcode-9-support/

  • SteveGraddySteveGraddy ✭✭ USUniversity ✭✭

    All of that was done before I realized I had no 11.0 simulators

  • TimNTimN Member

    I have this same issue, and XCode was not updated recently. While working on a project, I had a number of iOS simulators but now they are all missing. I'm not sure what I did to eliminate them all. This all occurred within a 30 min time frame.

  • TimNTimN Member

    Update: I re-logged into my Apple Developer account, then Quit/Restarted Xamarin on my Mac. Now, several of my configuration reappeared including "Debug | iPhone-Simulator" which displays the various simulators.

    However, if I change to another configuration (such as "Debug") and then return to "Debug | iPhone-Simulator", all simulator options no longer appear and I can only select my device.

Sign In or Register to comment.