Error installing Xamarin.GooglePlayServices.Maps

Hi!

I'm trying to follow this guide for using Google Maps in my Xamarin.Android project, but when I try to install the NuGet package I get this message:

Error       Could not install package 'Xamarin.GooglePlayServices.Maps 42.1021.1'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v6.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

I followed the instructions exactly and have Google Play Services installed. What's going on?

Answers

  • ITMAGEITMAGE USMember ✭✭
    edited September 28

    I experienced this as well and the below is what worked for me:

    Fully updated Xamarin components via Visual Studio (I'm using VS 2015)

    Tools > Options > Xamarin > Other : Check Now

    Added two Android SDKs (can be done through VS or using the Android SDK manager)

    Tools > Android > SDK Manager

    and ticked the boxes for (and then clicked INSTALL PACKAGE of course) :

    • Android 7.0 (API 24) > SDK Platform
    • Android 7.1.1 (API 25) > SDK Platform

    Set the project's PROPERTIES to use Android 7.1

    Project properties > Application > Compile using Android Version (Target Framework): Use latest platform (Android 7.1 (Nougat))

Sign In or Register to comment.