Crash iOS 11 version on iOS 10 EXC_CRASH abort() called in AD HOC

JorgenJorgen USMember ✭✭

I tested an app under the new iOS11 that will be released and it crashed on some screen on a button that was NULL (while that is working already for 5 years). Well I 'fixed' that one with checken for NULL so we solve it quickly. Then the whole app works just fine.

Only: when I install the same app on iOS10 I get a crash and I can not get information. It is directly after the launch screen and before it has the time to load the code to start UIApplication.Main. It happens in AD-HOC mode and not in DEBUG.

In the device log I get:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Triggered by Thread: 0

Application Specific Information:
abort() called

Filtered syslog:
None found

Thread 0 name: tid_403 Dispatch queue:
Thread 0 Crashed:
0 libsystem_kernel.dylib 0x000000018a899014 __pthread_kill + 8

If I google for "Application Specific Information: abort() called", I see a result in the last 23 hours also about iOS11 but I'm not allowed to see the content of the ticket here:

Hope there is someone who has an idea since iOS11 will come out in a few days and we need to have a fixed version in the store.

Xamarin Studio Community
Version 6.3 (build 864)
Installation UUID: 3e1de573-8051-4d34-a020-f6f32c510260
Mono (d15-3/14f2c81) (64-bit)
GTK+ 2.24.23 (Raleigh theme)

Package version: 502000224


Version: 1.5.5
Location: /Applications/Xamarin Profiler

Xamarin Inspector
Version: 1.2.2
Hash: b71b035
Branch: d15-1
Build date: Fri, 21 Apr 2017 17:57:12 GMT

Apple Developer Tools
Xcode 8.3.3 (12175.1)
Build 8E3004b

Version: (Xamarin Studio Community)
Hash: 8a391069
Branch: d15-3
Build date: 2017-08-28 16:51:11-0400

Version: (Xamarin Studio Community)

Build Information
Release ID: 603000864
Git revision: 6c2f6737278ccc3e81e12276d49c0d92f975f189
Build date: 2017-04-24 11:26:01-04
Xamarin addins: d8d46e577d8507c35260ce9d73df3c33415bb214
Build lane: monodevelop-lion-d15-1

Operating System
Mac OS X 10.12.6
Darwin UsersMac.local 16.7.0 Darwin Kernel Version 16.7.0
Thu Jun 15 17:36:27 PDT 2017
root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64

Enabled user installed addins
JSON Copy 1.1


  • PeterMillsPeterMills GBMember ✭✭

    I have exactly the same problem!!! Did you ever fix it?

  • JorgenJorgen USMember ✭✭

    @PeterMills yes, I think it had to do with switching from Testflight to local development version. I think if you remove the app from the device and do a clean and rebuild (maybe also restart your development machine) it will work.
    I'm not sure what did the trick eventually but it started to work again mysteriously.

  • PeterMillsPeterMills GBMember ✭✭

    Damn, Apple are getting the error too. My TestFlight just crashes out with no information.

    I've tried using our VSTS build agent and locally, but no difference. I thought the clean might do it, but doesn't appear to have helped.

    I'll keep at it!

  • BlentGenBlentGen USMember

    I am having same problem, debug running great on device and simulator but ad-hoc builds on testflight fail just after launch without a crash report .

    trying several options to build but cant succeed yet.

    Any idea or solution advice?

  • BlentGenBlentGen USMember

    Not sure that is the solution but I could run a build from test flight
    read it from other topic in this forum

    I use debug build which is running ok on device

    from ios project properties - debug setting
    - unchecked debugging
    - Select distribution sign
    - Select Create IPA file

    then submit the ipa file from debug directory and it works on testflight

  • rtushartusha Member
    edited September 2018

    @BlentGen, your solution worked for me in AdHoc mode. You have saved me :)

    Tried for a solution for 4 days but nothing worked and fed up because app is crashing for no reason/no errors.

    Apple/Xamarin should resolve this issue.

Sign In or Register to comment.