Lost all IOS Simulator

PierreSavardPierreSavard CAMember ✭✭

Hi experts!
I am new in the wonderful world of Xamarin. Yesterday, I Install Xamarin on my VS2017 and on my Mac Mini installed no ElCapitan (10.11.3). Then I compile the basic template "Welcome to xamarin forms". Selecting IphoneSimulator I got several simulator available (Iphone, Ipad, ...) But when running the code I got an error asking me to upgrade XCode to version 8.3 min (Avalaible only with Sierra OS).
So today I reinstall the Mac mini with Sierra (10.12.6) then reinstall Xamarin and XCode 9. I reconnect the Mac Agent in VS2017 and all working but now I do not have any simulator in the IOS project. I select: Debug->IphoneSimulator->App1.iOS and the only choice are Simulator and Device. When I select Simulator and run the project, I got this error: "Please select a valid device before running the application."

Any suggestion?

Posts

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    @PierreSavard,

    Sorry for the confusion! Unfortunately, you picked an interesting time to jump in and update! A new Xcode 9 was just released by Apple yesterday and we are working on getting compatibility for this out. Keep an eye on https://releases.xamarin.com for an announcement of support for this version of Xcode 9. Once that is posted you can download the compatible versions.

    Otherwise, you can visit https://developer.apple.com and go to the Downloads section and manually download Xcode 8.3.3 to use with the existing Xamarin tooling you have.

  • PierreSavardPierreSavard CAMember ✭✭

    -_- Wrong timing!
    I uninstall XCode9 and install 8.3.3 and all work good now. Thanks for your help!

Sign In or Register to comment.