Installation of Visual Studio for Mac

Hi, I've installed Visual Studio for Mac and my Mac and it seems to have installed OK. It said I also need MONO which I installed from http://www.mono-project.com/download/. This seemed to install OK as well. When I launch Visual Studio it gives the following error:

Could not launch Visual Studio
This application requires xamarin.mac native library side-by-side please download and instal the latest version of mono

I've tried re-installing both and received installation successful messages.
I'm an old school programmer, this is all new to me. I'd really appreciate some help. Thanks.

Best Answer

Answers

  • TimothyRisiTimothyRisi USXamarin Team Xamurai

    Hi Brian,

    It sounds like you installed just VSfM by itself, then installed Mono separately? Try installing from the universal installer, which should install everything required at the same time.

  • ChrisHamonsChrisHamons USXamarin Team Xamurai

    There are version requirements between the various packages, and for example if you installed a mono that was much too old for a given VSfM you might run into issues.

    The universal installer handles all of that for you.

  • BOKABOKA GBMember ✭✭

    Hi Chris, Timothy, Thanks for your responses.
    I believe I am using the universal installer.
    I did it again using the link in Timothy's response.
    When prompted I chose to install Visual Studio, Android, IOS, macOS and workbooks and inspector.
    The installation was very quick (because I guess I've already installed it).
    I got a message to say the installation was successful and a button to launch Visual Studio.
    When I click on the launch button I get the same error.

  • NavedDeshmukhNavedDeshmukh USMember
    edited September 12

    I tried installing VS 2017 Community for Mac for the first time. I am facing the same issues.
    The installation was successful but when i launch VS 2017 from launchpad. It shows the error.

  • BOKABOKA GBMember ✭✭

    Chris, Your suggestion to try uninstalling everything has worked !! I now have Visual Studio Community running on my Mac - I guess that's what I wanted. I'm trying to work my way through a Writing Your First Application in Xamarin Pluralsight course. Thank you so much for your help. It's much appreciated. Regards, Brian.

Sign In or Register to comment.