Google Play Services Rev 12 stopped working

Just today I had updated my SDK and re-built the Android app (targeting API 15), using the Google Play Services rev 12 component.
When running it the application actually crashed. I soon found out I had to add a new meta data item to the manifest:
<meta-data android:name="com.google.android.gms.version" android:value="@integer/google_play_services_version" />
and that resolved the crash, but the MapFragment just does not show anything.

My device is a Galaxy S3, the installed Google Play Services is at version 4.0.33.

I performed these steps to fix the issue, but all without success:

  • Manually rebuilt the GooglePlayServices bindings library as explained for the map and location demo v2.
    (had to add some meta-data to get it to build) and replaced the Xamarin component with a reference to this library. Builds OK, but same result.

  • Downloaded the old rev 12 SDK library from http://dl.google.com/android/repository/google_play_services_3265130_r12.zip
    (took a long time to find), replaced rev 13 with this one in the Extras folder of the SDK. Reverted my project back to
    its original state. Builds OK, but same result.

  • Tried the Froyo version of the component, but gave up when it would have required too many source code changes.

The logger shows a "Google Play Services resource not found" message in every case.

The question is, if I had not updated my SDK, would it still work? Or is the older SDK library (rev 12) not compatible with my newer Google Play Services version installed on the device. My second fix attempt would suggest that.

Any pointers?

Posts

  • KarlWaclawekKarlWaclawek CAMember ✭✭

    Fixed it - here is what happened:

    The day before I had to re-install Xamarin.Android after the Visual Studio plugin stopped working when I updated to 4.10.1. The re-install had to be done repeatedly and only became successful when I really wiped everything, including all references in the registry.

    As a result, the new install would create a new debug keystore and a new debug key. Therefore my application entry in the Google API Key record became invalid and I had to repeat the original procedure with the SHA1 finger print of the new debug key.

    So, in conclusion, it was sufficient to simple add that meta-data entry to the manifest and for me the rev 12 component works with rev 13 of the Google Play Services SDK library.

  • NinaVyedinNinaVyedin USXamarin Team, University, XamUProfessors Xamurai

    Hi Karl,

    Thanks for letting us know. We're working on making the google play services component experience better for you guys.

    Nina

  • AlexSotoAlexSoto MXXamarin Team Xamurai

    Hello

    We have new Google Play Services libraries available at

    Google Play Services

    Google Play Services (Gingerbread)

    Google Play Services (Froyo)

    Please note that Google stopped supporting Froyo on latest Rev 13 so Froyo flavour of the library is Rev 12 based

    Alex

Sign In or Register to comment.