Error using DragCoordinates() or any Swipe() method (Cannot implicitly convert type void to object)

ColinBuckColinBuck USMember ✭✭
edited August 22 in Xamarin Test Cloud

This is a new error that just started happening with my xamarin ui tests. I never had an issue before, but now whenever my tests hit anything that involves swiping or dragging the screen, this exception is thrown:

System.Exception : Error while performing SwipeRightToLeft(All().Index(0), 0.67, 500, True)
----> System.Exception : Error while performing Swipe(All().Index(0), "left", 0.67, 500, True)
----> System.AggregateException : One or more errors occurred.
----> Microsoft.CSharp.RuntimeBinder.RuntimeBinderException : Cannot implicitly convert type 'void' to 'object'

I have no idea why this is now being thrown when it wasn't before. It actually successfully swipes and moves the screen, but it throws this exception at the same time and fails the test.

I am using xamarin.UITest 2.0.10, nunit 2.6.4, most updated version of nunit test adapter, etc.

I have ran the tests in both Visual Studio and Rider, and am using MacOS 10.12.6

Thanks in advance for any ideas on what I should do to fix this new bug

Tagged:

Best Answer

Answers

  • ColinBuckColinBuck USMember ✭✭

    Edit: can confirm this is a 2.0.10 bug. Rolled back to 2.0.9 and it worked fine again. Feel free to move this post to wherever is best for reporting bugs and also if anyone wants to double check to make sure I am correct here I think that would be a good call, since this is only a single anecdote

  • Kent.GreenKent.Green USXamarin Team Xamurai
    edited August 24

    Can you reach out to support by logging into testcloud.xamarin.com & clicking on "Support" in the menubar?

    In particular, it would be helpful if you're able to share your Xamarin.UITest source code to reproduce the issue & an IPA or APK to run it against or a link to the issue occurring in the Xamarin Test Cloud.

  • Kent.GreenKent.Green USXamarin Team Xamurai

    I have some good news, one of my colleagues was able to reproduce the issue after all; and based on that is filing a bug report. You can still keep the email support channel in mind if you encounter other suspected bugs in the future though.

  • MariaAlexandrovaMariaAlexandrova USMember ✭✭

    I am getting same issue after updating Xamarin.UITest from v9 to v10. Hopefully you will fix this issue soon :blush:

  • SimonSndergaardSimonSndergaard DKXamarin Team Xamurai
    edited August 29

    I've pushed a potential fix to -dev, could you please update to 2.0.10.1638-dev and report success/failure here.

    Thanks,
    /Simon

  • SimonSndergaardSimonSndergaard DKXamarin Team Xamurai

    Bill,

    Thanks for the feedback.

    /Simon

  • FabienMwambaFabienMwamba USMember

    I had the similar issue running Xamarin.UITest 2.1.3 on macOS 10.12.6 with Xamarin.Forms 2.4.0.18342, i solved it by updating the Xamarin.UITest to the latest stable release which now is 2.1.4

Sign In or Register to comment.