Forum Visual Studio

VS2017 15.3.1 preview 1 won't install the 5 Xamarin Preview updates in Extensions and Updates

LesCandleLesCandle USMember ✭✭

I just updated to VS2017 15.3.1 preview 1.

In Extensions and Updates, I show Updates (5) and they are for Xamarin Preview (5)

I clicked on each one and each update button. They download and now there's a tiny clock icon in the upper right of each of the 5 items. I can see at the bottom : "Your changes will be scheduled. the modifications will begin with all Microsoft Visual Studio windws are closed".

I can see each item listed in 'Scheduled for Update' in the bottom right of the window.

However, I've closed VS2017 - and waited a while. When I open it back up again, Extensions and Updates shows the same 5 Xamarin Preview updates available. The tiny clock icon is gone. If I click on a row, there's an update button again which will download the same update Again.

Unsure how to proceed? Back in the old days, updates would get stored in C:\Users\MyName\AppData\Local\MonoDevelop-4.0\Cache\TempDownload and I could run them myself, but ... that folder is empty.

Best Answer

  • LesCandleLesCandle USMember ✭✭
    Accepted Answer

    VS 2017 15.4.0 Preview 1 seems to have resolved my problem, everything seems to be installed properly now.


  • LesCandleLesCandle USMember ✭✭
    edited August 2017

    I figured out part of the problem. I tried to use the feature inside VS to report the problem, and Microsoft said my login authentication had expired (even though my name showed in the upper right of VS2017 as logged in).

    I logged in and was able to install 3 of the updates (the VSIX updater ran after I closed VS and installed Xamarin.Android.SDK, , etc.)

    However, the 'Mono Debugging for Visual Studio' would not install. When it ran in VSIX, I got a dialog 'VSIX Installer' "The selected extensions are already installed to the specified SKU"

    And more importantly, I got a VSIX Installer "Modification failed. Some modifications could not be applied successfully. for the VERY IMPORTANT Xamarin.Apple.SDK.

    I'm including the log file.

    When I went back into Extensions and Updates, Xamarin.Apple.SDK now longer shows as needing an update? Only the Mono Debugging for Visual Studio is still there. I've tried the Mono Debugging update several times, it downloads each time, but never installs and I can't get it out of the updates list.

    How can I confirm all is ok, especially as it reported a failed update of the VSIX?

    Xamarin.Android.SDK shows up as installed and in the 'About Visual Studio' dialog, but Xamarin.Apple.SDK does not show up in either the Installed Tools and Extensions or the the 'About Visual Studio' dialog.

    BTW - I would strongly suggest putting my name in bold RED in the upper right if I need to re-login to the Visual Studio, as there was no indication.

  • prashantvcprashantvc USXamarin Team Xamurai

    I believe it was you that reported this bug
    I have marked it as confirmed, and reported the engineering team, I will keep you updated as soon as I hear anything

  • LesCandleLesCandle USMember ✭✭

    Prashant - thank you for looking at the problem so quickly! How do I proceed? What for a fix or un-install Xamarin and re-install?

  • LesCandleLesCandle USMember ✭✭
    Accepted Answer

    VS 2017 15.4.0 Preview 1 seems to have resolved my problem, everything seems to be installed properly now.

Sign In or Register to comment.