Xamarin automation tests ios. Failed to launch DeviceAgent

JuniorDJuniorD RUMember

Hello, can't launch UI auto tests on my ipad.
Error - Xamarin.UITest.XDB.Exceptions.DeviceAgentException : Failed to launch DeviceAgent ExitCode: 65
App is installed on device. DeviseAgent installed while trying to run any test.

ios version of ipad 10.3.3
xcode 8.3.3

in appProject:
Xamarin.TestCloud.Agent - ver. 0.20.7

in testProject:
NUnit - ver. 2.6.3
Xamarin.UITest - ver 2.0.10

Test setup:
app = ConfigureApp
.iOS
.InstalledApp(somebundle)
.StartApp();

About profiles also looks like everything is ok.

The thing is - test are running on another device (ipad with ios 9.2)
and some time ago were running on current device (from time to time). So that should not be problem with ios version compatibility.

Also tryed to delete folder 'xdb';

May it be problem of compatibility packages versions?
Any ideas?

Answers

  • JuniorDJuniorD RUMember

    While I'm trying to resolve this issue - i got feeling that the problem in provisioning profile. Looks like some way app install more than one PP or trying to use old one. For now it's only guess. I'll write result of checking it.

  • AnandGummadilliAnandGummadilli USMember
    edited March 2018

    I faced same issue while running UI tests in iPhoneSimulator. I have resolved the issue..

    Few things to check.
    1) Update Xamarin.TestCloud.Agent package from iOS project
    2) Update Xamarin.UITest package from UITest project
    3) Delete all folders from
    /Users/yourusername/Library/Developer/CoreSimulator/Devices

    4) Select "Enable Device Specific Builds" in iOS project options.
    5) Rebuild the iOS project
    6) Start running your UI test, Your Startapp() method should be able to launch your app in device/simulator.

  • deepakkg88deepakkg88 Member ✭✭

    I am unable to launch app in iOS real device.I have tried all the above suggestions.Could you please help?

    I am using development provisioning profile, Xamarin uitest-2.2.4,Nunit-2.6.4,X-code-9.2

    I have tried by deleting xdb folder as well.But no luck.
    I am getting below error:
    SetUp : Xamarin.UITest.XDB.Exceptions.DeviceAgentException : Failed to launch DeviceAgent

    ExitCode: 65
    IDEDerivedDataPathOverride = /var/folders/77/lc3w5ldx6cg8h6c9ykh00klmwydhgh/T/xdb/logs/2018.04.05.114011/DerivedData
    IDETestRunSpecificationPath = /var/folders/77/lc3w5ldx6cg8h6c9ykh00klmwydhgh/T/xdb/DeviceAgent.iOS.Dependencies/9a7eae887a041f733c06f5eef3e12600/ipa/DeviceAgent-Runner.app/PlugIns/DeviceAgent.xctest/DeviceAgent-device.xctestrun

    Reason: no suitable image found. Did find:
    Referenced from: /var/containers/Bundle/Application/888CB66C-5B84-4ACA-BFC4-5447623694BA/DeviceAgent-Runner.app/DeviceAgent-Runner
    } (10.3.2 (14F89))
    applications: (null)
    buildVersion: 14F89
    connected: yes
    connectionType: direct
    developerDiskMountError: (null)
    deviceActivationState: Activated
    deviceArchitecture: arm64
    deviceAvailableCapacity: 3589308416
    deviceClass: iPhone
    deviceIdentifier: 6319e0786c19f1d174c641023cc3b2a9c2acb2bd
    deviceIsActivated: YES
    deviceIsBusy: NO
    deviceIsTransient: NO
    deviceName: iPhone 6S
    deviceSerialNumber: DNQQH2MJGRY5
    deviceSoftwareVersion: 10.3.2 (14F89)
    deviceTotalCapacity: 12310880256
    deviceType:
    hasInternalSupport: NO
    identifier: 6319e0786c19f1d174c641023cc3b2a9c2acb2bd
    ignored: NO
    isPasscodeLocked: NO
    isSupportedOS: YES
    isWirelessEnabled: no
    productVersion: 10.3.2
    provisioningProfiles: (null)
    supportedDeviceFamilies: (
    /private/var/containers/Bundle/Application/888CB66C-5B84-4ACA-BFC4-5447623694BA/DeviceAgent-Runner.app/Frameworks/XCTest.framework/XCTest: code signing blocked mmap() of '/private/var/containers/Bundle/Application/888CB66C-5B84-4ACA-BFC4-5447623694BA/DeviceAgent-Runner.app/Frameworks/XCTest.framework/XCTest'
    /private/var/containers/Bundle/Application/888CB66C-5B84-4ACA-BFC4-5447623694BA/DeviceAgent-Runner.app/Frameworks/XCTest.framework/XCTest: code signing blocked mmap() of '/private/var/containers/Bundle/Application/888CB66C-5B84-4ACA-BFC4-5447623694BA/DeviceAgent-Runner.app/Frameworks/XCTest.framework/XCTest'
    bootArgs:
    (null)
    )
    ** TEST EXECUTE FAILED **
    /var/folders/77/lc3w5ldx6cg8h6c9ykh00klmwydhgh/T/com.apple.dt.XCTest/IDETestRunSession-1E7F26B4-2E42-4EE5-98F9-F06FF8D09A6F/Unnamed-Test-Run-24C29F5C-CEBF-4A53-AEB6-6E86DA231BCC/Session-Unnamed-Test-Run-2018-04-05_114013-XdXdpc.log
    2018-04-05 11:40:13.332 xcodebuild[27251:6518349] [MT] IDETestOperationsObserverDebug: (9DE6E019-2C82-44BB-889A-86742B673139) Beginning test session Unnamed-Test-Run-9DE6E019-2C82-44BB-889A-86742B673139 at 2018-04-05 11:40:13.332 with Xcode 9C40b on target {
    2018-04-05 11:40:13.332 xcodebuild[27251:6518400] IDETestOperationsObserverDebug: Writing diagnostic log for test session to:
    2018-04-05 11:40:15.606 xcodebuild[27251:6518349] Error Domain=IDETestOperationsObserverErrorDomain Code=6 "Early unexpected exit, operation never finished bootstrapping - no restart will be attempted" UserInfo={NSLocalizedDescription=Early unexpected exit, operation never finished bootstrapping - no restart will be attempted}
    dyld: Library not loaded: @rpath/XCTest.framework/XCTest
    User defaults from command line:

Sign In or Register to comment.