2 errors with VS 2013

wallymwallym Wally McClureUSInsider, Beta ✭✭✭

I just installed the Xamarin.iOS 1.8 plugin for VS and loaded up an existing project. I am getting two errors that I am not quite sure how to resolve:

  1. Failed to clean build cache on the server.

  2. Identifier is not set in ios application property page (easily fixable).

  3. Application name is not set (easily fixable).

Is there any way to force a clean up of the cache on the build server? Is there something on my build server that is causing this issue?

Wally

«1

Posts

  • wallymwallym Wally McClure USInsider, Beta ✭✭✭

    Items 2 & 3 seem to be different behavior than what I see on iOS with XS. I don't believe that I have to have those items set there.

  • PhilHarrisPhilHarris Phil Harris USMember

    ok - I am also having the same issue, and have been dialoging with Support.
    These 429 errors come back from the mtbserver:
    1. Build - Failed to clean build cache on the server
    2. Try to launch Simulator - Failed to change active application on server
    3. Clean console - Failed to clean console log on the server.
    4. Additionally, IOS will not build or deploy or debug from VS.IOS

    No idea what is causing the issue. Stumped.

  • wallymwallym Wally McClure USInsider, Beta ✭✭✭

    ooops, my title is 2, but it should be 3. :-)

    I finally got this to work on my Windows machine and talking to my mac. Unfortunately, the only devices that I can select are:
    iPhone Retina, iPad, and iPad Retina. There does not seem to be a simulator option. Has that been removed?

  • PhilHarrisPhilHarris Phil Harris USMember

    Wally M - What did you do to get rid of the Failed to clean cache on server errors ? Desperately need help here.

    1. To get the simulators to show up, you have to putz around with the Configuration manager. There is some weird relation ship with the combo boxes. Set Active solution platform first, then select the Platform iPhone Simulator. Uncheck deploy. The simulators will appear.
  • NandoNando Fernando Ghedin USMember

    I'm facing the same issue here. Right after installing Xamarin.iOS 1.8 plugin for VS, I cannot build my project anymore, due to this "Failed to clean build cache on the server" error.
    Wally-M - could you share your solution with us?
    Thank you!

  • PabloBenitezPabloBenitez Pablo Benitez USMember

    Having the same 2 issues plus 1 warning plus at Options-> Xamarin -> iOS Setting I only get and error : Unable to load property sheet.

    Error 1 Application Name is not set in iOS Application Property Page
    Error 2 Identifier is not set in iOS Application Property Page
    Warning 3 Version is not set in iOS Application Property Page

  • PabloBenitezPabloBenitez Pablo Benitez USMember

    Ok, I edited Info.plist list now I only see this error:
    Error 1 Connection to Xamarin.iOS Build Host failed. Double click here to select a server. Xamarin.iOS Extension.
    But double click does nothing.

  • PabloBenitezPabloBenitez Pablo Benitez USMember

    I manually added this key to the regisry:
    MonoTouchBuildServerAddress
    with the ip of the Mac Host as the value and now I get this error:

    Error 1 Build server with address 10.2.2.170 is too old to be used with this version of Xamarin.iOS extension. Double click here to select a new server. Xamarin.iOS Extension

  • PJBeamanXPJBeamanX PJ Beaman USXamarin Team Xamurai

    Hi all,

    The Bundle Identifier and Application Name errors are intentional. During testing, we found that not setting these values resulted in very hard to diagnose errors. In a future release, these values will be auto-generated as they are in Xamarin Studio.

    @Fernando, @wallym:

    We'll need to investigate the cause of the failure to clean the build server cache. Thank you for the report. You can clean the build cache manually by deleting the contents of this folder:

    ~/Library/Caches/Xamarin/mtbs/
    

    If you are still in the state where the failure to clean the cache occurs, we may be able to glean some information from the Mac Server output (from VS) and the Trace.0 log. The Trace.0 file would be located at the following paths:

    %LOCALAPPDATA%\Xamarin\Log\MonoTouchVS\[11.0|10.0]\Trace.[0|1|2].log
    

    @PabloBenitez:

    Can you confirm the version information of the VS extensions you have installed by checking in Tools -> Extensions and Updates? It's possible the issue you're seeing on the iOS Settings page is due to incompatible VS extensions installed.

    Thanks everyone, hopefully we can resolve all of your issues as quickly as possible.

    PJ

  • TimothyRisiTimothyRisi Timothy Risi USXamarin Team Xamurai

    @PabloBenitez:

    Can you also confirm the version of Xamarin.iOS you have installed on the build host? The last error you listed sounds like it's possible you updated the extensions in Visual Studio but didn't update the mac as well. You can see the version number of Xamarin.iOS you're using on the Xamarin.iOS Build Host or under About Xamarin Studio from XS.

    The current stable version of Xamarin.iOS for mac is 7.0.4.209. If you are not on that version, try updating from Xamarin Studio and see if that fixes the problem with pairing from Visual Studio.

    -Tim

  • PabloBenitezPabloBenitez Pablo Benitez USMember

    Visual Studio 2013, W7 Pro, Xamarin iOS 1.8.361
    At Mac Host I'm currently (at this exact moment) updating to 7.0.4.

  • NandoNando Fernando Ghedin USMember

    Hello PJ! Thank you for your reply.

    I have removed the files from the '~/Library/Caches/Xamarin/mtbs/' directory, but unfortunately I'm still not able to build the iOS project from Visual Studio.

    Here goes some info:

    On my Windows 7 Professional (SP1), there is:

    • Visual Studio 2012 (version 11.0.60610.01 Update 3).
    • The latest Xamarin Studio Plug-in for Visual Studio available today (Xamarin.iOS_Setup-1.8.361.0_signed.msi).

    On the Mac, I have OS X 10.9.

    Right after firing a build, what I see at the Visual Studio error list is:

    2 Failed to clean build cache on the server (error)
    1 Failed to obtain information about the remote's profile files. Unable to check SDK status (warning)
    

    By double-clicking on the first error, this is the message that shows up:

    Failed to clean build cache on the server
    Server command 'CleanRemoteCache': failed to clean build cache on the server
    Command execution task ended with exception
    Exception System.Net.WebException: The remote server returned an error: (429).
    Exception details can be found in the log file
    

    And here are the new lines added to the Trace.0.log:

    Mono.IOS.VisualStudio.MonoTouchPackage Error: 0 : [2013-11-14 18:13:33.3] Exception caught.
    System.Net.WebException: The remote server returned an error: (429).
       at System.Net.HttpWebRequest.GetResponse()
       at MonoTouch.Tools.Utilities.BuildServerClient.ServerIO.Server_GetResult[T](String command, IDictionary`2 queryVariables)
    Mono.IOS.VisualStudio.MonoTouchPackage Error: 0 : [2013-11-14 18:13:33.3] Xamarin.iOS encountered the following error(s):
    System.Exception: Failed to clean build cache on the server (Generic)
    Server command 'CleanRemoteCache': failed to clean build cache on the server
    
    Command execution task ended with exception
    
    Exception System.Net.WebException: The remote server returned an error: (429).
    
    Exception details can be found in the log file
    

    The new Xamarin.iOS Build Host is up and running (successfully paired with VS). One strange thing is that when I start a build, nothing happens on the server side (there's no new lines added to mtbserver.log after the build).

    If you need any additional information, I'll be glad to help.

    Thanks a lot!

    Fernando

  • NandoNando Fernando Ghedin USMember

    Hello PJ,
    It really seems to be related to some faulty communication with the server. Please take a look at the "diagnostic view" attached.
    Thanks!
    Fernando

  • wallymwallym Wally McClure USInsider, Beta ✭✭✭

    Thanks @pjbeamanx for the explanation. :-)

    On cleaning up my other errors, iirc, I just did a set of reboots yesterday, reconnected to my mac host, and it all worked. Realistically, I have no idea what really fixed this.

  • PabloBenitezPabloBenitez Pablo Benitez USMember

    I now have anything updated but I'm experiencing all the same problems.
    Can anyone confirm that the manual edit I did at the registry is ok?
    I added the key MonoTouchBuildServerAddress with value the IP of the Mac Host.
    Per my understanding the pair process starts when I hit the run at my VS Solution, right?

  • TimothyRisiTimothyRisi Timothy Risi USXamarin Team Xamurai

    Hello @PabloBenitez,

    The pairing process should start when you open an iOS project in Visual Studio. If it does not, or you cancel it at that time, there's a couple of ways to start the process. First, if you have the iOS toolbar displayed you can click the "Refresh build server info" button (it looks like 2 arrows making a circle). You can also go to Tools -> Options -> Xamarin -> iOS Settings and click the "Find Mac Build Host" button. You shouldn't have to manually add the IP address to the registry. The "Connect to a Xamarin.iOS Build Host" window for the pairing process should show all build hosts on the same network that have the Build Host app running.

    From that window you select the build host you want to pair with and after a couple of seconds it should display a new window asking for a PIN number. Go to the build host and click the "Pair" button if you haven't already and it will display the PIN to enter in Visual Studio.

  • wallymwallym Wally McClure USInsider, Beta ✭✭✭

    @philharris thanks for reminding me about the configuration manager. Now, I'm running.

  • PabloBenitezPabloBenitez Pablo Benitez USMember

    Thanks @TimothyRisi !

    At Tools -> Options -> Xamarin -> iOS Settings I only see an error saying error at loading property page.
    I don't have any iOS Toolbar, where is it?
    Xamarin.iOS version 1.8.365

    Microsoft Visual Studio Professional 2013
    Versión 12.0.21005.1 REL
    Microsoft .NET Framework
    Versión 4.5.50938
    Versión instalada: Professional
    Microsoft Office Developer Tools para Visual Studio 2013 ESN 06177-004-0444002-02914
    Microsoft Office Developer Tools para Visual Studio 2013 ESN
    Team Explorer para Visual Studio 2013 06177-004-0444002-02914
    Microsoft Team Explorer para Visual Studio 2013
    Visual Basic 2013 06177-004-0444002-02914
    Microsoft Visual Basic 2013
    Visual C# 2013 06177-004-0444002-02914
    Microsoft Visual C# 2013
    Administrador de paquetes NuGet 2.7.40911.287
    ASP.NET and Web Tools 2013.1.41009
    Microsoft Web Developer Tools contains the following components:
    Support for creating and opening ASP.NET web projects
    Browser Link: A communication channel between Visual Studio and browsers
    Editor extensions for HTML, CSS, and JavaScript
    Page Inspector: Inspection tool for ASP.NET web projects
    Scaffolding: A framework for building and running code generators
    Server Explorer extensions for Windows Azure Web Sites
    Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Windows Azure
    ASP.NET Web Frameworks and Tools 2012.2 4.1.21001.0
    ASP.NET Web Frameworks and Tools 2013 5.0.11001.0
    Depuración remota de Windows Azure 1.0
    Herramientas comunes de Windows Azure 1.0
    Herramientas de servicios móviles de Windows Azure 1.0
    Herramientas de servicios móviles de Windows Azure
    Herramientas de Workflow Manager 1.0 1.0
    PreEmptive Analytics Visualizer 1.2
    SQL Server Data Tools 12.0.30919.1
    Microsoft SQL Server Data Tools
    Windows Azure Tools 2.2
    Windows Azure Tools para Microsoft Visual Studio 2013 - v2.2.11003.1601

  • TimothyRisiTimothyRisi Timothy Risi USXamarin Team Xamurai

    @PabloBenitez,

    If you go to View -> Toolbars there should be an iOS option, this has the device selector and some build host related buttons. Based on the error you got trying to go to the iOS settings, I wonder if there was an issue with your install for the iOS extension. If you go to Help -> About Visual Studio does Xamarin.iOS show up in the list?

  • PabloBenitezPabloBenitez Pablo Benitez USMember

    @TimothyRisi
    No, it doesn't. It does shows at Tools -> Extensions with Xamarin Shell, though.

    I don't recall any issue at intalling, also I installed 1.8.365 today (I previously had 1.8.361).

  • RodneyFoleyRodneyFoley Rodney Foley USMember, Beta

    I too am having the issues Wally detailed. With the only unfixable one right now being the cache issue. I tried everything listed in the thread with no success. I hope this is resolved soon as I can't build or deploy any iOS projects right now, this is a critical blocking issue on your latest 1.8 release.

  • BrendanZagaeskiBrendanZagaeski Brendan Zagaeski USForum Administrator, Xamarin Team Xamurai

    A bug has been filed for the "CleanRemoteCache" / HTTP server response code 429 issue here: https://bugzilla.xamarin.com/show_bug.cgi?id=16242

  • NandoNando Fernando Ghedin USMember

    Thank you Brendan! Shall we wait for a hot-fix in the next few days? Just like Rodney, I'm not able to build/deploy my iOS project anymore :-(

  • BrendanZagaeskiBrendanZagaeski Brendan Zagaeski USForum Administrator, Xamarin Team Xamurai

    I'm not yet sure what the timeframe will be on fixing this. Hopefully soon! If you like, you can temporarily downgrade back to the previous stable versions until this problem is resolved:

    • Xamarin.Android 4.8.3 (4.8.03015)
    • Xamarin.iOS 1.4.2.0
    • Xamarin.iOS 7.0.2 (7.0.2.7) for the Mac build host

    You can download these versions from https://store.xamarin.com/account/my/subscription/downloads (as mentioned here).

    Note that it's important to downgrade both Visual Studio extensions at the same time (Xamarin.Android 4.8.3 with Xamarin.iOS 1.4.2). Downgrading should not affect your license or activation state.

  • NandoNando Fernando Ghedin USMember

    Thank you once again for the support, @BrendanZagaeski. I have successfully downgraded the applications (both on Mac and Windows) and now the build/deploy works fine again.

  • HaroldLMarzanHaroldLMarzan Harold L. Marzan USMember

    Thank you Brendan! I got Xamarin.iOS working smooth now on both Mac and Windows.

    I'll keep with this version until the hot fix be published and safe, to download and upgrade to the latest version.

    It's time to lift the rocket!

  • SD.8765SD.8765 S D USMember

    But do these versions have that full PCL support promised to come with 1.8 on VS?
    What's the features difference in such downgrade? May be silly question since new version does not work either way but anyway :)
    I also faced the issue that almost none of the PCL in nugget currently support my project if I enable IOS and Android platforms. So it kinda makes the whole story useless :(

  • JoeSaporitoJoeSaporito Joe Saporito USMember

    That fixed my issues!! Thanks!

  • RodneyFoleyRodneyFoley Rodney Foley USMember, Beta

    That fixed the issue, I hope you guys will be updating your documentation and error message to be more specific and able to detect this kind of issue.

  • AndresGutierrezAndresGutierrez Andres Gutierrez CLMember

    Thanks......

  • IlincescuMihaiIlincescuMihai Ilincescu Mihai USMember

    I have installed today 3.12.2013, created a new project hello world for IOS and this issues are still not yet fixed. Is annoying to rollback after I stayed 1 hour to install it and install a previous version. From the start is having bugs.. not god.

  • DaveWrightDaveWright Dave Wright GBMember

    I've spent much of today trying to work out where I'm going wrong here, but adjusting the time worked for me. My PC clock was about 4 minutes different to my Mac clock, and setting them to be the same time made it work like magic.

  • KevinFanKevinFan Kevin Fan CAMember, University

    I got the same issue in VS2013.

  • GavinMannionGavinMannion Gavin Mannion USMember

    Fixing the time on the mac solved the problem for me... thanks for that

  • MarcoTeodoroMarcoTeodoro Marco Teodoro USMember

    i have the same issue. date time are the same on windows 8.1 and mac os maverick.

    I have the connections well establish and the sdk are the same version, yet i can't compile the code. i have rebooted windows and mac and i still can't compile the app.

    Should i manually define plist info?

  • pinedaxpinedax Andres Pineda USUniversity, Developer Group Leader ✭✭

    I saw i had the same date/time on both Windows and Mac but a few seconds were in difference. After setting both machines to point to the same internet time provider "time.apple.com" I am now able to build from Visual Studio 2012...

    A whole day lost but at least it's already up and running.. Thx

  • NandoNando Fernando Ghedin USMember
    edited January 2014

    Also got it working after synchronizing the clocks via time.apple.com. Thank you Brendan!

  • ZoharAdar.9449ZoharAdar.9449 Zohar Adar USMember

    After synchronizing the clocks between the pc and mac everything work like a magic..
    Also now I can see the app running on the iOS simulator, I couldn't do that before.

  • irfan.1970irfan.1970 irfan USMember

    getting below error while executing the IOS App:

    Error 1: Application Name is not set in iOS Application Property Page
    Error 2: Identifier is not set in iOS Application Property Page

«1
Sign In or Register to comment.