Xamarin.UITest version 2.0.10

Xamarin.UITest version 2.0.10 is available from NuGet. What changes does it make? The release notes page still lists 2.0.9 as the most recent.

Best Answer

Answers

  • Nomad461Nomad461 USMember ✭✭

    Thanks!

  • AnthonyMehallelAnthonyMehallel USMember ✭✭✭
    edited August 16

    Hi,

    I updated the xamarin.UITest library (2.0.10), Now, when I run my UI tests on iOS, I have the following error message : SetUp : System.Exception : Test Cloud Agent version 0.20.6 or later is required. Version 0.20.4 was detected. Can you specify the procedure to update the Test Cloud Agent on macOS Sierra. I run my tests on iOS native application (objective C).

    So I need to update calabash-sandbox ?! https://developer.xamarin.com/guides/testcloud/calabash/configuring/osx/calabash-sandbox/

    Thank you,
    Anthony

  • EricMooneyEricMooney USMember

    Running into this same issue...digging to try to figure out how to update the Test Cloud Agent version as well.

  • EricMooneyEricMooney USMember

    Ok, feeling kinda dumb. For me, UI testing a Xamarin project, I just had to update the version of Calabash in the target app I am trying to test rather than in the UITest project itself...then redeploy and test worked.

  • AnthonyMehallelAnthonyMehallel USMember ✭✭✭

    Hi @EricMooney ,

    can you specify your procedure to update the version of Calabash ?

    Thank you,

    Anthony

  • EricMooneyEricMooney USMember

    @AnthonyMehallel because I build a Xamarin C# app, it was as simple as letting NuGet update the Calabash DLL for me to the latest version and then the error went away. In the image below, the reference in the red box was out of date.
    Please excuse the silly test project names I was using; I was trying to keep myself amused while dealing with this annoying issue.

    I do not know if this will be helpful to you since you are testing a native app -- but perhaps it is the same issue and can be fixed in a slightly different manner. I don't know too much about packages / references in objective c land, but I assume there has to be a way to bring things up to date as well...

    BTW this was an eye-opener for me, I didn't realize that the actual app to be tested needed to reference the Xamarin.TestCloud.Agent before this.

  • AnthonyMehallelAnthonyMehallel USMember ✭✭✭

    Hi @EricMooney ,

    ok, my problem is different because I automate native applications (swift or objective C) not Xamarin.IOS.

    For Xamarin.IOS : We use Xamarin Test Cloud Agent
    For Native App iOS : Calabash.

    Anthony

  • EricMooneyEricMooney USMember

    @AnthonyMehallel
    I totally get it, and I'm sorry I don't have the answer.
    That being said: in my quest to solve my own issue, I went down some weird roads that involved upgrading Ruby to the latest version, which involved rbenv and bundler, which I believe calabash-sandbox makes use of (depending on how your system is setup).

    According to the calabash github page, this may bring you up to date:

    $ cd ~/my/project
    
    # Update your Gemfile to point to the version of the gems you want.
    # gem "calabash-cucumber", "0.20.5"
    # gem "calabash-android", "0.9.1"
    
    $ calabash-sandbox
    [me@calabash-sandbox]$ bundle update
    

    Although you may need to update other components (such as Ruby, rbenv, brew, bundler, all of which I attempted in my quest to get this working)

  • AnthonyMehallelAnthonyMehallel USMember ✭✭✭

    I have update the calabash-cucumber (0.20.5) + calabash-android (0.9.0) +Xamarin test Cloud (2.1.2)

    but in my fold calabash.framework/Resources/version, the Test Server doesn't update. I have juste one version 0.20.4 ... I think it's a bug from Calabash.

    So, I copy past the folder Calabash.Framework from this project : https://github.com/calabash/ios-smoke-test-app to my project. Now I have all Test Servers Versions.

    And it works !

Sign In or Register to comment.