the linkassemblies task failed unexpectedly

abdoelzamalkawyabdoelzamalkawy EGMember ✭✭✭

Hello everyone,
i finished my app in debug mode and now i want to release it
when i build it in release mode i got this error

i searched a lot but i didn't solve it
thanks

Answers

  • N_BauaN_Baua INMember ✭✭✭✭✭

    @abdoelzamalkawy ,

    Try changing your linker properties as ( Linker --> Linking ) to 'None'.
    (If this works, set to ( Linker --> Linking ) to 'SDK assemblies only'.)

    Also make sure, you've unchecked your debug options and fast deployment options in android project properties.

    Hope this helps.
    Regards,
    N Baua

  • abdoelzamalkawyabdoelzamalkawy EGMember ✭✭✭
    edited July 2017

    @N_Baua
    i did all this
    if i changed linker to none it will work but it will generate a huge size file
    if i return it back to assemblies only it won't run

  • N_BauaN_Baua INMember ✭✭✭✭✭

    @abdoelzamalkawy,

    Okey can you check the logs and determine what's not being bundled,
    May be that's what you'll have to include when linker tries to rip it off.

    Regards,
    N Baua

  • abdoelzamalkawyabdoelzamalkawy EGMember ✭✭✭

    @N_Baua
    where should i find the log file :smile:

  • abdoelzamalkawyabdoelzamalkawy EGMember ✭✭✭

    @N_Baua
    This is the details of the error
    i have updated everything
    all nuget plugins and android sdk

  • N_BauaN_Baua INMember ✭✭✭✭✭
    edited July 2017

    @abdoelzamalkawy said:
    where should i find the log file :smile:

    OR


    and step 2

    Make sure you read between the lines, many things do not appear that fishy in logs.

    Regards,
    N Baua

  • abdoelzamalkawyabdoelzamalkawy EGMember ✭✭✭

    @N_Baua

    the log won't display any thing
    but the output windows logged this error

Sign In or Register to comment.