'Visual Studio Emulator fro Android' is not able to connect Internet

I launched the 5" KitKat (4.4) XXHDPI Phone API Level 19 from 'Visual Studio Emulator fro Android' with VS2017 Enterprise, but it can't connect to Internet. And its Wi-Fi is not able to turn ON.

Posts

  • BozhiQianBozhiQian AUUniversity ✭✭


    This is screenshot of emulator. No newwork to be connected and is not able to configure to connect to Internet. I don't know how. Thanks.

  • BozhiQianBozhiQian AUUniversity ✭✭

    I run the 5.7" Marshmallow (6.0.0) from Visual Studio Emulator for Android.


    But I am not able to turn on Wi-Fi in the emulator.

  • VulcanVulcan TWMember ✭✭✭
    Open Hyper-V manager.

    If you have only one virtual switch, add another for Internet.
  • BozhiQianBozhiQian AUUniversity ✭✭

    Hi Vulcan, Thanks for your help.
    I tried but I was not able to resolve it so I removed the new virtual switch.
    Let me show you for all of my current configuration so you can check where I should change.

    Virtual Switch Manager

    Hyper-V Manager

    For the selected Emulator, I opened the "Settings..."

    These are all my network adapters.

    Network and Sharing Center

    (you can see the Windows Phone Emulator Internal Switch has no network access).

    So what I should I do now?

  • VulcanVulcan TWMember ✭✭✭
    For the selected Emulator, I opened the "Settings..."

    Add New network for Virtual switch which can connect Internet.
  • BozhiQianBozhiQian AUUniversity ✭✭

    First I try to add new virtual switch at "Virtual Switch Manager".

    I choosed the network adaper from my DELL docker (DispayLink). And I clicked Apply.

    Now this new vEthernet take over previous one with Internet access.

    Now click the "Setting..." for the selected emulator, and I switch to the new Virtual Switch.

    Open the "Visual Studio Emulator for Android"

    Launch the 5" KitKat (4.4) XXHDPI Phone.

    Now the emulator did not launched,

    And there is no activity of active emulator to be started in Hyper-V Manager.

  • BozhiQianBozhiQian AUUniversity ✭✭

    The emulator was actually launched after while but keeping at "OS is starting..." for 15 minutes. It finally pop up dialog message.


    Now the emulator stop at "OS is starting..." forever.

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    I suppose it will be better to uninstall and reinstall the VSE4A. Because my setting are similar and I have no issue.

  • BozhiQianBozhiQian AUUniversity ✭✭

    Thanks Shantimohan,
    Actually I did this yesterday but it does not work.


    Is it latest version?

    I guess from the pop up dialog with message "Couldn't auto-detect the guest system IP address", the guest (emulator) and host (my machine) has the same IP as they are using the same vEthernet that I just created. Do you have any idea to solve this issue? Thanks.

Sign In or Register to comment.