Cannot compile projects after upgrading to Xcode 4.6.2

StephaneCordonnierStephaneCordonnier Stephane CordonnierFRMember ✭✭


I updated Xcode this morning (version 4.6.2) and right now, I cannot compile my projects.

Error: A valid Xcode installation could not be found. If your copy of Xcode is installed to a non-standard prefix, please specify the location in Xamarin Studio's Preferences under 'SDK Locations'

I checked that SDK Locations are good but still same problem.

Any ideas to solve this problem ?

Thanks in advance



  • TomonobuGondoTomonobuGondo Tomonobu Gondo JPMember

    I have same issue.

  • OlgaSteidlOlgaSteidl Olga Steidl CHMember

    The same to me

  • VincentNguyen-HuuVincentNguyen-Huu Vincent Nguyen-Huu USMember

    Same issue any news about it ?

  • JonCortezJonCortez Jon Cortez USMember, University

    I am also seeing the same issue. I also noticed the following:

    1. When double-clicking any .xib or .storyboard files, it gets opened now as XML files and not in IB.
    2. The list of simulators is gone from the drop-down for debugging.
  • DenisMillerDenisMiller Denis Miller RUMember

    Same thing

  • alexstalkeralexstalker alex stalker USMember

    removing XCode 4.6.2 and installing XCode 4.6.1 worked for me.


    Same thing

  • ChrisHardyChrisHardy Chris Hardy GBForum Administrator, Xamarin Team Xamurai

    There is a known issue with Xcode 4.6.2, we would recommend that you re-download Xcode 4.6.1 and continue using that until we get a fix out for Xamarin Studio. You can re-download Xcode 4.6.1 from

  • StephaneCordonnierStephaneCordonnier Stephane Cordonnier FRMember ✭✭

    Removing 4.6.2 and reinstalling 4.6.1 solved the problem.

  • HaDuyenHoaHaDuyenHoa Ha Duyen Hoa USMember

    Me too. Thanks :)

  • a-marina-marin alexandra marin ROMember

    hi, i cannot find xcode 4.6.1 in the list. the newest i can see is 3.2

    can anyone help?

  • Bob_ReckBob_Reck Bob Reck USMember ✭✭✭

    Thanks Chris!

  • DirkoSwanepoelDirkoSwanepoel Dirko Swanepoel ZAMember
    edited April 2013

    @chrisntr is this a XCode issue, or is it an issue with MonoDevelop that will be fixed in a future release?

  • OlgaSteidlOlgaSteidl Olga Steidl CHMember
    edited April 2013

    The problem that new Xcode has got new structure of App and Mono as I understand will be updated to work with new version.

  • GregoryHillGregoryHill Gregory Hill USMember

    How quickly will this patch be made available? I'd really like to work with the Xamarin examples, but don't want to regress back to Xcode 4.6.1.

  • GregoryHillGregoryHill Gregory Hill USMember

    And is it possible to direct the current version of Xamarin to look in the right place?

  • NikitaPshenovNikitaPshenov Nikita Pshenov THMember
    edited April 2013

    I went to but cannot find anything beyond xcode 3.2. Where is xcode 4.6.1?

    PS - I am a Mac noob and frankly I hate it.

  • AbooAboo Aboo USMember

    Same problem here. Downloading XCode 4.6.1 :S

  • siancusiancu Stelian Iancu CHMember

    @NikitaPshenov it's right there, in the list, the 10th entry.

    980 x 1148 - 188K
  • AbooAboo Aboo USMember

    After replacing the new XCode with the old one the issue is solved.

  • HautzendorferMartinHautzendorferMartin Hautzendorfer Martin USMember

    I have the same issue. Do you have to have a paid developeraccount to see the 4.6.1 version of Xcode?

    2013-04-17 15_57_35-Downloads.png
    790 x 934 - 69K
  • siancusiancu Stelian Iancu CHMember

    I don't think so. I logged in with one of my old Apple IDs which is for sure not a paid account and I can see it. I guess you need a valid Apple ID.

  • NikitaPshenovNikitaPshenov Nikita Pshenov THMember

    But I do have a valid Apple ID...

  • CraigJohnsonCraigJohnson Craig Johnson USMember

    I have experienced the same issue. My free developer account (that I just created last night) has no recent versions of xcode available. Checked my coworkers paid account and the versions were there.

  • ChrisHardyChrisHardy Chris Hardy GBForum Administrator, Xamarin Team Xamurai

    We just released Xamarin Studio 4.0.4 with support for Xcode 4.6.2, this is on the stable channel so you should get that through the updater.

  • siancusiancu Stelian Iancu CHMember

    @chrisntr will there be a new version on the alpha channel as well? I wanted to check out the new stuff announced at Evolve.

  • HautzendorferMartinHautzendorferMartin Hautzendorfer Martin USMember

    Is it possible, that the new Version of Xamarin Studio on Mac respectively the buildserver doesn't work with the MonoVS Tools?

  • JeremyKolbJeremyKolb Jeremy Kolb USMember ✭✭

    Unfortunately Visual Studio needs the change as well.

  • GregoryDouguetGregoryDouguet Gregory Douguet FRMember
    edited April 2013

    Still have build server problem with Xamarin Studio 4.0.4

  • GuillaumeZahraGuillaumeZahra Guillaume Zahra FRMember

    Yes, Xamarin Studio 4.0.4 with Xcode 4.6.2 doesn't work with Visual Studio...I mean, it say that this is unreachable (and in detail, say that files are differents from the mac server).

    I think there is a missing update for Visual Studio installation ?
    Keep up the good work !

Sign In or Register to comment.