Deployment failed because of an internal error: Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE]

JohnMurrayJohnMurray John MurrayGBMember

Has anyone any ideas on this - i can build but not debug - simply refuses to deplaoy with above error
I have tried to build totally new app then add bits of this app one by one
Even with all the support files and classes in and all references (but the Oncreate method is left to be just a simple button as per demo) this works So it does not seem to be a conflict with any reference
I mean what update is incompatible with what ? I am completely stumped

help

Posts

  • ChrisHardyChrisHardy Chris Hardy GBForum Administrator, Xamarin Team Xamurai

    There's more information on this issue on our troubleshooting page here: http://docs.xamarin.com/guides/android/troubleshooting#11.installfailedupdateincompatible-when-installing-a-package hopefully this will give you some more information to resolve the problem.

  • GerryHighGerryHigh Gerry High USMember, Beta ✭✭

    FWIW I'm now getting this error on the alpha branch on OSX Mavericks. Same source/phone compiles/deploys fine from Xamarin Studio alpha on Windows 8.

  • GerryHighGerryHigh Gerry High USMember, Beta ✭✭

    I was able to get it to install (as explained here https://bugzilla.xamarin.com/show_bug.cgi?id=12639)

  • DavidReynoldsDavidReynolds David Reynolds USMember

    I also got this same error but had a different reason. My package name was empty. According to Xamarin docs I should have gotten a different error but I got this one. To fix in Visual Studio 2012 (will be slightly different for other IDE's) right click on your Android project and select Properties. Select the Android Manifest tab and ensure you have a package name with a '.' in it. The dot is important or it will not work.

  • GerryHighGerryHigh Gerry High USMember, Beta ✭✭
    edited October 2013

    FWIW this came up again today. I wound up having to do an

    adb uninstall package-name

    to get it to work.

    Gerry

  • bosikovbosikov Eugene Bosikov USMember

    You have a the same application installed from Google store or from package that was prepared for deploy. Go to Settings->Apps select your application and uninstall. It will fix all your problems.
    After that you will able to run and debug your application from IDE.

  • BenBishopBenBishop Ben Bishop USMember, Beta

    To add to the knowledge base of this issue, I ran into a similar issue where I had a version installed from TestFlight. When I would do a build on my iMac from XS directly to the device, I'd get an error saying the install was incompatible. Reinstalling from TestFlight, and then uninstalling it, and then installing from XS worked.

    With that said, I also ran into an issue where I had a build on my device that was generated by my iMac. When I tried to install a new build from my Macbook Pro via XS, I got the same incompatible install issue. I had to go back to my iMac, reinstall the app, uninstall it, and then try installing from my MBP.

    Long story short, whenever switching machines or delivery mechanisms, always manually uninstall the previous version!

  • ZacharyCardozaZacharyCardoza Zachary Cardoza USMember

    Same issue for me. I uninstalled app, but some "ghost" files remained. Solution was to build APK and install from SD/Memory and then uninstall.

  • ianmercerianmercer Ian Mercer USMember ✭✭

    For me it appears that a missing Application Icon was the cause of this error message, or at least it went away when I added one.

  • SagarPanwalaSagarPanwala Sagar Panwala USMember

    @EugeneBosikov‌ ,It's work.

  • JohnMurrayJohnMurray John Murray GBMember

    Just to help others
    I eventually found that this error also happens if one has a release or other version installed on the machine on which you are debugging. In my case a previous release had been downloaded from the store and installed on my test machine.
    Uninstalling this 'release' or previous version removed the Error message and problem

    JM

  • VincentPoirierVincentPoirier Vincent Poirier CAMember ✭✭

    If you can't find the App through the normal listing, it'll be visible in the settings in the App section. In my case, it was installed on a (haha...?) non-existing SD card. But that's definitely the fix, uninstalling the App from the device one way or the other.

  • ckranjckranj Ranjith Tch INMember

    @EugeneBosikov thanks a lot. It is working

  • NkechiNnajiNkechiNnaji Nkechi Nnaji USMember

    For me, there were two reasons why I received this error.

    Reason 1: I was deploying my application to a device which used API level 16. Even though my manifest showed I had API level 16, in actual fact it was empty. So through Android SDK manager, I installed the required API level for the device.

    Reason 2: Thank you, @VincentPoirier! I didn't realize that sometimes when you deploy unsuccessfully to your device, the application may download to the device though it may not show on the home screen of the device that the application has been downloaded to the device. So I had to go to the settings of the device, located my list of applications installed on the device and then deleted the application in question. Viola!

    I ran the application and it worked!!!

  • mr-incrediblemr-incredible Spencer Roberts USMember

    Burned yet another hour on this bug this morning. Thanks @VincentPoirier. that turned out to be my issue as well. Ugh.

Sign In or Register to comment.